fglrx 8.40.4 no funciona

Luego de un par de horas tratando de hacer funcionar los drivers de mi ATI en mi laptop, me rendí y volví a la versión 8.38.6.

¿Síntomas?

  1. Al reiniciar por primera vez, el driver no funcionaba.
  2. Al reiniciar las siguientes veces, todo parecía funcionar hasta que se reiniciaba X, o nos cambiábamos a una tty. Ante cualquiera de estos eventos, el equipo dejaba de responder y la pantalla se ponía de colores.
  • OpenSuSE 10.2
  • Kernel 2.6.18.8-0.5
  • ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

Conclusión, la versión 8.40.4 de los drivers para las tarjetas de video ATI no funcionan!

PD: (Eso me pasa por no haber cambiado notebook cuando debia. 😛 )

Instalando Quickcam Messenger

Mientras que estudiaba física 120 “siento muerte”, hablaba con mi amorcito…

Y en uno de mis arranques de locura, decidí instalar mi webcam en mi Linux openSuSE 10.2

Una rápida búsqueda en google, me llevó al sitio http://home.mag.cx/messenger/, desde donde bajé los drivers.


[rcovarru@metano:~]$ su -l
metano:~ #
metano:~ # cd
metano:~ # wget http://home.mag.cx/messenger/source/qc-usb-messenger-1.6.tar.gz

Lo primero que vamos a hacer, es preparar nuestro kernel para recibir estos módulos.
Antes de prepararlos, debemos estar seguros de tener los headers del kernel.
(En mi openSuSE, tengo instalado el paquete kernel-source.)
metano:~ # yum install kernel-source

Si estamos seguros que tenemos los headers, preparamos nuestro kernel:

metano:~ # cd /usr/src/linux
metano:/usr/src/linux # make oldconfig
metano:/usr/src/linux # make prepare

Con nuetro kernel listo para recibir los felices módulos de la webcam…

metano:~ # cd
metano:~ # tar -xvf qc-usb-messenger-1.6.tar.gz
metano:~ # cd qc-usb-messenger-1.6/
metano:~/qc-usb-messenger-1.6 # export MODULE_DIR=/lib/modules/$(uname -r)
metano:~/qc-usb-messenger-1.6 # export LINUX_DIR=/usr/src/linux
metano:~/qc-usb-messenger-1.6 # ./quickcam.sh

Y seguimos las instrucciones…. que en este caso, si todo está correcto… serian muchos <enter>. 😛

Ahora bien, quizas les pueda reclamar por el compilador usado en nuestro sistema. Si eso les ocurre lo que tiene que hacer es:

metano:~/qc-usb-messenger-1.6 # export CC=gcc

Y ahora ejecutar el instalador automático (quickcam.sh)

Si queremos probar si todo funciona, podemos instalar el paquete xawtv…

metano:~/qc-usb-messenger-1.6 # yum install xawtv

Ahora, yo además lo probé y configuré con éxito en mi amsn SVN r8854

Continue reading “Instalando Quickcam Messenger”